テクノツールのロゴ
オペレートナビTT3.5
設定ガイド <第3.5版>

目次

1章 設定を始めよう
1.1 どんな設定をするの?
1.2 設定の流れ
1.3 どこで設定するの?
1.4 セットファイルを選ぶ
1.5 セットファイルを作成・編集する
1.6 設定内容を印刷する
1.7 旧バージョンのオペレートナビの設定を利用する
1.8 設定のバックアップをとる(エクスポート)
1.9 設定を復元する(インポート)
1.10 オペレートナビを再起動する
2章 入力装置
2.1 入力装置を選ぶ
2.2 スイッチの押し方を設定する
2.3 スイッチでオンスクリーンキーボードを操作できるようにする
2.4 スイッチで直接マウスを操作する
2.5 スイッチを押したときの動作を設定する
2.6 マウス・キーボードの動作をスイッチに登録する
2.7 テンキーを使用する
3章 オペレートナビの画面
3.1 アプリケーションを「AP起動」キーボードに登録する
3.2 「AP起動」キーボードのアプリケーションの順番をかえる
3.3 オンスクリーンキーボードを表示する位置を変更する
3.4 必要ないときにオンスクリーンキーボードを消す
3.5 配色や文字の大きさを変更する
3.6 オンスクリーンキーボードを追加する
3.6.1 「KB切替」キーボードに表示する/しないを切り替える
3.6.2 非表示になっているキーボードをセットファイルに追加する
3.6.3 他のセットファイルや標準添付のセットファイルから取り込む
3.6.4 他のPCで使っているキーボードファイルをコピーする
3.7 不要なキーボードファイルを削除する
3.8 キーボードファイルの順番を変える
3.9 オペレートナビが起動したときに開くキーボードを変更する
3.10 作成したキーボードファイルを別の環境で利用する(エクスポート)
3.11 別のPCで作成したキーボードファイルを読み込む(インポート)
3.12 今操作している部分を目立たせる
3.13 現在操作している内容を画面に表示させる
3.14 よく使う文章を、素早く入力する(語句補完機能)
3.14.1 語句補完機能を有効にする
3.14.2 登録語句を新しく追加する
3.14.3 登録されている語句を編集・削除する
3.15 IMEを自動で起動させる
4章 音
4.1 文章を読み上げる
4.2 読み上げ箇所を拡大表示する
4.3 操作時に音を鳴らす
4.4 最後まで読み上げてからスキャンを移動する
4.5 音声でフォーカス位置を読み上げる
4.6 読み上げを聞きやすくする(速度や声質の調整をする)
4.7 特殊な読みを登録する
4.8 登録した読み方を変更する
4.9 読み上げ用ユーザ辞書をコピーする
5章 マウスポインタ
5.1 移動の速さを変更する
5.2 長く移動する場合は速さを変える
5.3 マウスポインタが自動で止まるまでの時間を変更する
5.4 画面端での動作を変更する
5.5 移動の方向を変更する
5.6 マウスポインタをみつけやすくする
5.7 ジャンプ位置を登録する
6章 オンスクリーンキーボード
6.1 オンスクリーンキーボードを作る(操作の手順)
6.2 キーボードファイルを使用するアプリケーションに関連付ける
6.3 行列数を増やす
6.4 表示サイズを変更する
6.5 大きなボタンを作る
6.6 キーのレイアウト(位置)を変更する
6.7 キーボードの縦・横を入れ替える
6.8 キーに表示する名前を登録する
6.9 キーに絵を表示させる
6.10 ボタンに説明を添える(絵と文字両方を表示させる)
6.11 キーの読み上げの際の名前を登録する
6.12 キーの読み上げに、録音音声を使う
6.13 同じキーを連続して選択できるようにする
6.14 ほかのキーと違う色やフォントのキーを作る
6.15 キーを押したときの動作を登録する
6.16 アプリケーションを起動する
6.17 キーボードやマウスを使う操作を登録する
6.18 よく使う文章を、1回のキーの選択で入力する
6.19 指定したオンスクリーンキーボードに切り替える
6.20 音声ファイルを再生する
6.21 マウスによる操作を登録する
6.22 距離を指定してマウスポインタを動かす
6.23 画面に残った残像を消す
6.24 キーボードによる操作を登録する
6.25 繰り返し操作を登録する
6.26 操作間の待ち時間を登録する
6.27 スキャンの際のグループを設定する
6.28 不要なキーを削除する
6.29 1行、1列をまとめて削除する
6.30 行や列を挿入する
6.31 キーの間に隙間を入れる
6.32 マウスポインタのジャンプ位置を設定する
6.33 キートップ、または操作列設定だけを連続して登録する
6.34 既に設定されているキーをコピーする
6.35 特定のキーボードだけ色やフォントを変更する

はじめに

本書では、より利用者に適した操作環境を実現するための「オペレートナビ設定」プログラムの使い方について説明します。オペレートナビ設定の各設定項目については『設定リファンレスガイド』でも説明していますので、合わせて参照ください。

メモ
オペレートナビEX(Ver3.0)より設定ファイルの構成や設定方法が変わりました。オペレートナビEX(Ver2.1)以前のバージョンからオペレートナビTT3.5をお使いになる場合は、設定マニュアルを今一度熟読されることをお勧めします。

ご注意

  1. マニュアルの内容の一部または全部を無断転載することは禁じられています。
  2. マニュアルの内容に関しては将来予告なしに変更することがあります。
  3. マニュアルの内容については万全を期して作成いたしましたが、万一ご不審な点や誤り、記載漏れなどお気づきのことがありましたら、当社へご連絡ください。
  4. 当社では、本製品の運用を理由とする損失、逸失利益等の請求につきましては、3.項にかかわらずいかなる責任も負いかねますので、予めご了承ください。

商標について

[目次に戻る]

1章 設定を始めよう

1.1 どんな設定をするの?

オペレートナビTT3.5をインストールした直後は1つのスイッチで操作できるように設定されていますが、より使いやすいように、スキャン方式や速度、オンスクリーンキーボードなどを変更することができます。

例えば、次のような設定があります。

<Q&A>

最低限の設定だけでとりあえず使ってみたいのですが。

あらかじめ設定が用意されている"標準セットファイル"がありますので、『はじめにお読みください(導入ガイド)』や『標準セットファイル 簡易ガイド』をご覧ください。
使い慣れてきたら本書をご覧になり、ご利用形態に合った設定の見直しをされることをおすすめします。

[目次に戻る]

1.2 設定の流れ

多くの設定項目がありますので、サンプルの"標準セットファイル"を使ってオペレートナビを操作し、ご利用状況に合わせて設定変更を繰り返していくことをお勧めします。

一例として、次のような流れがあります。
  1. "標準セットファイル"を引用してセットファイルを新規作成
  2. スキャンの速度や効果音の音量などの調整
  3. マウスポインタの速度などの調整
  4. 起動アプリケーションの登録
  5. キーボードファイルの作成・編集

メモ
キーボードファイルは、他のオペレートナビのユーザーや支援者が作ったものを使うこともできます。

メモ
ご利用者の体調に合わせて、午前中はセットA、午後はセットBとセットファイルを切り替えて操作することもできます。

<Q&A>

設定を変更してうまくいかなかった場合に心配なのですが。

設定を変更する前にセットファイルを別名で保存しておくか、エクスポートしておくと、後で元に戻すことができます。

[目次に戻る]

1.3 どこで設定するの?

「オペレートナビ設定」で、スキャン方法や速度、キーボードの作成や編集などすべての設定を行います。

メモ「オペレートナビ設定」の起動方法

オペレートナビ設定は、オペレートナビが動作中であっても、オンスクリーンキーボードの操作によって設定変更できます。変更された設定情報は、ファイルを保存しオペレートナビを再起動することで反映されます。

[目次に戻る]

1.4 セットファイルを選ぶ

利用したい操作方法に合わせて、あらかじめ用意されているもの、または新しく作成したものの中から使用するセットファイルを選びます。あらかじめ用意されているセットファイルを使う場合は、『標準セットファイル 簡易ガイド』を参照してください。(初めてお使いになる場合は、あらかじめ用意されているものの中から選んで使ってみることをおすすめします。)

(1)「オペレートナビ設定」を起動します。

(2) メニューバーの「ファイル」→「ファイルを開く」を選択します。

(3) 開いた画面で使うセットファイルの名前のフォルダを開きます。

(4) フォルダと同じ名前のファイルがあるので、そのファイルを開きます。
画面上の設定内容が、選択したセットファイルの設定内容に変わります。

(5) メニューバーの「ファイル」→「通常利用するセットファイルに設定」を選択します。

[目次に戻る]

1.5 セットファイルを作成・編集する

セットファイルを作成する手順の概要を説明します。
まったく新しいセットファイルを作成する場合と、既存のファイルに追加・修正をする場合で、多少手順が異なります。

●標準セットを引用して新規作成する場合

(1) メニューバーの「ファイル」→「新規作成」→「標準セットから作成」を選択します。
「新規作成(引用)」画面が開きます。

(2) 引用する標準セットを選択し、「OK」ボタンを押します。
「インターフェイスセット名」画面が開きます。

(3) 「インターフェイスセット名」に作成するインターフェイスセットの名前を入力して「OK」ボタンを押します。

(4) 2〜6章を参照しながら設定を変更します。

(5) メニューバーの「ファイル」→「通常利用するセットファイルに設定」を選択します。

(6) メニューバーの「オペナビ」→「通常利用するセットファイルでオペレートナビを(再)起動する」を選択するとオペレートナビが起動し、編集した内容が反映されます。

●白紙の状態で新規に作成する場合

(1) メニューバーの「ファイル」→「新規作成」→「未設定の状態から作成」を選択します。
「インターフェイスセット名」画面が開きます。

(2)「インターフェイスセット名」に作成するインターフェイスセットの名前を入力して「OK」ボタンを押します。

(3) 2〜6章を参照しながら設定を行なっていきます。

(4) メニューバーの「ファイル」→「通常利用するセットファイルに設定」を選択します。

(5) メニューバーの「オペナビ」→「通常利用するセットファイルでオペレートナビを(再)起動する」を選択するとオペレートナビが起動し、編集した内容が反映されます。

●既存のファイルを編集する場合

(1) メニューバーの「ファイル」→「ファイルを開く」を選択して、編集するセットファイルを開きます。
(※ 現在使用しているセットファイルを編集する場合は、「オペレートナビ設定」起動時に読み込まれているので必要ありません。)

(2) 2〜6章を参照しながら設定を変更します。

(3) 変更が終わったらメニューバーの「ファイル」→「上書き保存」を選択します。
別ファイルとして保存する場合は「名前を付けて保存」を選択し、元のファイルとは別の名前で保存します。

(4) メニューバーの「ファイル」→「通常利用するセットファイルに設定」を選択します。
(※ 現在使用しているセットファイルを上書き保存している場合は、この手順は不要です。)

(5) メニューバーの「オペナビ」→「通常利用するセットファイルでオペレートナビを(再)起動する」を選択するとオペレートナビが起動し、編集した内容が反映されます。

[目次に戻る]

1.6 設定内容を印刷する

セットファイルで設定されている内容を、プリンタで印刷できるようにメモ帳に書き出すことができます。

(1) メニューバーの「ファイル」→「設定情報ファイル出力」を選択します。メモ帳が起動し、セットファイルの設定内容が表示されます。

(2) メモ帳の操作で内容を印刷します。

[目次に戻る]

1.7 旧バージョンのオペレートナビの設定を利用する

「オペレートナビ(Ver2.0)」「オペレートナビEX(Ver1.0/2.0/2.1)」で使用している設定ファイルをオペレートナビTT3.5 で使用できるように変換します。

メモ 「オペレートナビEX(Ver3.0)」「オペレートナビTT」「オペレートナビTT2」のセットファイルは、旧パソコン側でエクスポートし、オペレートナビTT3.5側でインポートすることにより使用できます。

メモ 「オペレートナビ(Ver1.0)」のファイルは変換できません。

【手順1】 変換元ファイルのコピー

旧バージョンのオペレートナビのパソコン内にある「set」フォルダを、オペレートナビTT3.5をインストールしたパソコンにコピーします。

【手順2】 設定ファイルの変換

(1) アプリビュー(すべてのアプリ)より「セットファイル変換」を選択して起動します。

(2)「バージョン」で、変更元のオペレートナビのバージョンの□にチェックを入れます。

(3)「セットファイル」に、新しいパソコンにコピーした「set」フォルダ内の変換したいセットファイルを直接入力するか、「参照」ボタンを押して開いた画面で選択します。

(4)「出力ファイル」に、変換したファイルを出力する場所とファイル名を直接入力するか、「参照」ボタンを押して開いた画面で選択します。

(5)「実行」ボタンを押すと、設定ファイルの変換が始まります。

(6)「進捗状況」のダイアログが消えたら、「閉じる」を押して変換は終了です。

(7) 変換したファイルを「1.9 設定を復元する(インポート)」の手順で、オペレートナビTT3.5の環境に読み込みます。

[目次に戻る]

1.8 設定のバックアップをとる(エクスポート)

PCを再セットアップする際や別のPCに同じ設定をコピーするために、セットファイルを圧縮ファイルにして書き出すことができます。

(1) メニューバーの「ファイル」→「ファイルを開く」で、書き出すセットファイルを開きます。

(2) メニューバーの「ファイル」→「エクスポート」を選択します。

(3)「保存する場所」欄に"デスクトップ"などの場所を指定します。

(4)「ファイル名」欄にはインターフェイスセット名に「.opz」がついたファイル名がすでに入力されています。ファイル名を変えたい場合はファイル名を入力し直して下さい。

(5)「保存」ボタンを押すと、エクスポートファイルが作成されます。

[目次に戻る]

1.9 設定を復元する(インポート)

「1.8 設定のバックアップをとる(エクスポート)」で作成したエクスポートファイルを元に、オペレートナビの設定を復元します。

(1)「オペレートナビ設定」を起動します。

(2) メニューバーの「ファイル」→「インポート」を選択します。

(3) インポートするファイルを指定します。

(4)「開く」ボタンを押すと設定の復元が実施され、オペレートナビ設定のタイトルバーに、復元したインターフェイスセットの名前が表示されたら復元完了です。

[目次に戻る]

1.10 オペレートナビを再起動する

オペレートナビ設定の画面からオペレートナビを起動、または再起動させることができます。

メニューバーの「オペナビ」の下にある、以下の何れかを選択します。

・通常利用するセットファイルでオペレートナビを(再)起動する:
"通常利用するセットファイルに設定"されているセットでオペレートナビを起動、または再起動します。
・現在編集中のセットファイルでオペレートナビを(再)起動する:
現在編集しているセットファイルを適用してオペレートナビを起動、または再起動します。

メモ 現在編集しているセットファイルが"通常利用するセットファイルに設定"されている場合は、どちらを選んでも同じです。

[目次に戻る]

2章 入力装置

この章では設定項目「入力方法」「スキャン方法」について説明します。

2.1 入力装置を選ぶ

オペレートナビを何で操作するかを設定します。

(1)「入力方法」を選択します。

(2)「スイッチ(スキャン)入力を利用する」「テンキー入力を利用する」「マウス入力を利用する」のうち、操作に利用する項目の□にチェックを入れます。
複数の項目にチェックを入れて、複数の入力機器で操作することも可能です。

ご注意
「マウス入力を利用する」にチェックが入っている場合、いくつかのアプリケーションではオペレートナビから操作できないことがあります。
ご利用者がマウスを使った操作ができる、またはご支援者が常にそばにいらっしゃる場合を除き、この設定は有効にしないで下さい。

[目次に戻る]

2.2 スイッチの押し方を設定する

オペレートナビでは、スイッチの押し方によって機能(スイッチコマンド)を変えることができます。例えば、1回押すと"スキャン開始"、2回押すと"オペナビメニュー表示"といった使い方ができます。

スイッチで操作する場合、スイッチを押した回数に応じて機能を変える「押した回数で機能実行」という設定と、スイッチを押し続けた時間に応じて機能を変える「押している時間で機能実行」という設定があります。

指先などで細かく連続してスイッチを押せる場合は「押した回数で機能実行」を、細かい操作ができない場合や手にふるえがあって1回に何度もスイッチを押してしまうといった場合には「押している時間で機能実行」を選択してみてください。

●押した回数で機能実行

この設定では、"連続でスイッチが押された回数"を判断するために「機能確定時間」という時間設定が必要になります。

例えば「機能確定時間」を「1.0秒」に設定した場合、1回スイッチを押してから1秒以上時間がたったときは、スイッチを1回押したときのスイッチコマンドが実行されます。1秒たつ前にもう1度スイッチを押したときは2回押した、と判断されます。2回目のスイッチ押下時点からさらに1秒以内に再度押下があった時は3回押したと判断されます。

ちなみに2回目までしか操作が設定されていないのにスイッチを3回押した場合は、普通にスイッチを押したときとは違う音がして、何もスイッチコマンドは実行されません。

「押した回数で機能実行」の場合の設定手順は次の通りです。

(1)「入力方法」を選択します。

(2)「スイッチ(スキャン)入力を利用する」の□にチェックを入れます。

(3)「押した回数で機能実行」を選択します。

(4)「機能確定時間」を入力します。

●押している時間で機能実行

スイッチの長短押しで機能(スイッチコマンド)の実行を行う場合は、次の2つの時間設定が必要です。

「入力確定時間」とは、スイッチを押し始めてから"スイッチを押した"と判断されるまでの時間で、0.1秒単位で設定します。手にふるえがあったり、まばたきによるスイッチを使っているような場合に、スイッチを押したつもりはないのに押したとみなされてしまうことを防ぐため、何秒以上押していない場合には押したとみなさない、という入力無視時間です。

「機能有効時間」は、何秒押し続けたら次の機能に切り替わるか、という時間で0.1秒単位で設定します。スイッチを素早くはなせないような場合には、この数値を長めにすることで、ゆっくり離しても目的の機能を実行できるようになります。

例えば、入力確定時間を「1.0秒」、機能有効時間を「1.5秒」と設定した場合、スイッチを押し始めて1秒後に"スイッチを押した"と判断され、それから1.5秒以内にスイッチを離すと1つ目に設定された機能が実行されます。ここで離さずに次の1.5秒が経過する前に離した場合は2つ目に設定された機能が実行されます。

「押している時間で機能実行」の場合の設定手順は次の通りです。

(1)「入力方法」を選択します。

(2)「スイッチ(スキャン)入力を利用する」の□にチェックを入れます。

(3)「押している時間で機能実行」を選択します。

(4) 入力確定時間を入力します。

(5) 機能有効時間を入力します。

[目次に戻る]

2.3 スイッチでオンスクリーンキーボードを操作できるようにする

スイッチを押してオンスクリーンキーボードを操作できるようにし、オンスクリーンキーボードの自動スキャンの速度や、スキャンを何回繰り返すかといった設定をします。

(1)「スキャン方法」を選択します。

(2)「キーボードスキャンを利用する」の□にチェックを入れます。

(3) キーボードスキャンを自動で行うか、手動で行うかを選択します。

自動キーボードスキャン
スイッチを押すとオンスクリーンキーボード上のカーソルが自動的に移動し、目的のキーを含むグループ、または目的のキーにカーソルが来たところでスイッチを押して選択する操作方法

手動キーボードスキャン
スイッチを押すたびにカーソルが1つずつ移動し、目的のキーまたはグループにカーソルが来たところで、カーソル移動とは別のスイッチ操作(スイッチコマンド)を行うことで選択する操作方法

(4)「スイッチ機能設定」ボタンを押して「スイッチ機能設定」画面を開き、スイッチを押したときの動作を設定します。設定の詳細については「2.5 スイッチを押したときの動作を設定する」を参照してください。

(5)「スキャン間隔」を入力します。
ここでは通常のスキャン速度を設定します。

(6)「スキャン間隔[高速]」を入力します。
ここで設定した速さは、スイッチ操作で「スピードアップ」を実行した時に適用されます。(ただし、標準セットファイルにはスピードアップ操作はありません。)

(7)「スキャン反復回数」を入力します。
キーボードスキャンを何周行うかを設定します。

[目次に戻る]

2.4 スイッチで直接マウスを操作する

オペレートナビには、スイッチを使ったマウスエミュレーション機能が2種類あります。

「画面スキャン」の設定手順は次のとおりです。

(1)「スキャン方法」を選択します。

(2)「画面スキャンを利用する」の□にチェックを入れます。

(3)「スイッチ機能設定」ボタンを押して「スイッチ機能設定」画面を開き、スイッチを押したときの動作を設定します。設定の詳細については「2.5 スイッチを押したときの動作を設定する」を参照してください。

※ 「ジャンプ位置設定」ボタンについては「5.7 ジャンプ位置を登録する」で説明します。

[目次に戻る]

2.5 スイッチを押したときの動作を設定する

最大5つのスイッチについて、どのスイッチを何回押したら(どれくらい押し続けたら)どんな機能(スイッチコマンド)を実行させるかという設定を行います。

ご注意
間違った設定を行うとオペレートナビの操作がうまくできなくなってしまう場合があります。設定変更の前にエクスポート機能でバックアップを取っておき、ご支援者とともに行うことをお勧めします。

(1)「スキャン方法」を選択します。

(2)「利用スイッチ数」欄に利用するスイッチの数を入力します。
利用できるスイッチの数は、1〜5個までです。

(3)「スイッチ機能設定」ボタンを押して、「スイッチ機能設定」画面を開きます。

ご注意「スイッチ機能設定」画面は、自動キーボードスキャン用、手動キーボードスキャン用、画面スキャン用と分かれています。

(4) 機能を設定するマスを選択します。

(5) 次の何れかの操作で「機能割当」画面を開きます。

(6)「コマンド」を選択してから▼を押してリストを開き、設定する機能を選択します。

(7)「OK」ボタンを押すと「スイッチ機能設定」画面に戻り、選択した設定がマスに表示されます。
「次へ」「前へ」ボタンを押すと隣接するマスの「機能割当」画面に移動できます。ただし、「OK」ボタンを押して「スイッチ機能設定」画面に戻るまで各マスの設定は登録されないので、「キャンセル」ボタンを押すとそれまでの連続するすべての設定が破棄されますのでご注意ください。

(8) すべてのマスの設定が終わったら、メニューバーの「ファイル」→「閉じる」を選択して「オペレートナビ設定」画面に戻ります。

(9) メニューバーの「ファイル」→「上書き保存」を選択します。

[目次に戻る]

2.6 マウス・キーボードの動作をスイッチに登録する

スイッチを押したときの機能(スイッチコマンド)として、キーボードスキャンや画面スキャンの動作だけでなく、実際のマウスやキーボードの動作を組み合わせた操作を登録することもできます。例えば、"Enterキーを押す"、"音を鳴らす"といった動作も実行できます。

(1) 機能を設定するマスの「機能割当」画面を開き、「複合操作」を選択します。

(2)「名称」欄に、登録する操作の名称を入力します。
スイッチ操作時に現れるインジケーターにも表示されますので、分かりやすい名称を入力してください。

(3)「操作列編集」ボタンを押して、「複合操作列編集」画面を開きます。

(4)「操作選択」の中から設定する項目を選びます。

(5) 選択した項目について内容を入力または選択し「操作列挿入」ボタンを押します。

(6) 間違えた内容を挿入してしまった場合は次の方法で削除できます。

(7) 登録した操作内容を「複合操作列」欄で確認し、問題がなければ「OK」ボタンを押します。

[目次に戻る]

2.7 テンキーを使用する

テンキーを使って、オンスクリーンキーボードやマウスエミュレーション機能を使用できるようにします。

(1)「入力方法」を選択します。

(2)「テンキー入力を利用する」の□にチェックを入れます。

(3)「キー入力確定時間」を入力します。
「キー入力確定時間」とは、何秒間キーを押したら"キーを押した"と判断されるか、という入力無視時間の設定です。手のふるえなどで意図せずに押されてしまう場合には、この時間を長めにしてみてください。初期設定の「0.0秒」はキーを押した時点で機能が実行されます。

[目次に戻る]

3章 オペレートナビの画面

この章では「オンスクリーンキーボード」「キーボード位置/配色」「アプリケーション登録」「語句補完」「インジケータ表示」「フォーカス強調」設定について説明します。
オンスクリーンキーボードのキーボード編集については、「6章 オンスクリーンキーボード」を参照ください。

3.1 アプリケーションを「AP起動」キーボードに登録する

アプリケーション登録を行うと、次のようにオンスクリーンキーボードからアプリケーションを起動できるようになります。

注意 Windowsストアアプリ(モダンUI)の登録は行えません。

(1)「アプリケーション登録」を選択します。

(2)「アプリケーション一覧」の中に登録したいアプリケーションがあるかを探します。

(3) 登録したいアプリケーションが一覧にある場合はそれを選んで「利用/解除」ボタンを押し、印を■に変えます。

メモ ■印は「AP起動」キーボードから起動できます。

(4) 登録したいアプリケーションが一覧にない場合は「追加」ボタンを押します。
開いた画面で実行したいファイルまたはショートカットを選択してください。

メモ アプリケーションのショートカットは、主に次の場所にあります。

ご注意 「アプリケーション登録」にはプログラムのリンク先(パス)情報が含まれています。
特に32ビット/64ビットパソコン間で設定ファイルの移行を行う場合はご注意ください。多くのアプリケーションのプログラムパスが異なるため、新しいパソコン側でアプリケーション登録を再度行うことをお勧めします。

[目次に戻る]

3.2 「AP起動」キーボードのアプリケーションの順番をかえる

「AP起動」キーボードに登録されているアプリケーションの順番を入れ替えます。よく使うアプリケーションは、上または左の方にくるように配置を調整すると良いでしょう。

(1)「アプリケーション登録」を選択します。

(2)「アプリケーション一覧」の中から順番を変えたいアプリケーションを選択します。

(3)「上へ移動」「下へ移動」ボタンを押すと、順番を上または下に1つずつ動かすことができます。

[目次に戻る]

3.3 オンスクリーンキーボードを表示する位置を変更する

オンスクリーンキーボードを表示する位置を4カ所まで登録できます。登録した表示位置は、オペレートナビの操作時、「(オペナビ)メニュー」→「オペナビウィンドウ操作」キーボードの「位置変更」キーを押すことで、順番に位置変更することができます。
初期設定では起動時は画面右上に表示され、「位置変更」キーにより左上、左下、右下と順に切り替わります。

(1)「キーボード位置」を選択します。

(2)「表示位置A」〜「表示位置D」の4つうち、登録する分だけチェックを入れます。
「オペナビウィンドウ操作」キーボードの「位置変更」キーでオンスクリーンキーボードを移動する必要がない場合は、1つにチェックするだけでも構いません。

(3)「基準位置」の▼を押してリストを開き、画面のどの角に表示させるかを選びます。

(4)「縦の距離」「横の距離」で、(3)で選んだ画面の端から何ドットずつ離すかを入力します。

メモ 標準セットファイルでは、オンスクリーンキーボードを右下、左下に表示させるときに、タスクバーが隠れないように下から32ドット離れるように設定しています。

(5) チェックを入れたほかの表示位置についても(3)、(4)を設定します。

[目次に戻る]

3.4 必要ないときにオンスクリーンキーボードを消す

オペレートナビ操作中、オンスクリーンキーボードを一時的に非表示にする方法は次のようにあります。

「(一定時間入力がなければ)自動的にキーボードを隠す」設定は、次のとおりです。

(1)「オンスクリーンキーボード」を選択します。

(2)「自動的にキーボードを隠す」の□にチェックを入れます。

(3)「待ち時間」で、何秒間操作をしなかったらキーボードを消すか、という時間を入力します。

[目次に戻る]

3.5 配色や文字の大きさを変更する

オンスクリーンキーボードの配色や文字の大きさを見やすいように変更できます。

(1)「キーボード配色」を選択します。

(2)「フォント」の▼を押してリストを開き、キーボード上で使用したいフォントを選択します。

(3)「フォントサイズ」に、表示する文字の大きさを入力します。
文字の大きさは「表示例」に表示されている文字を参考にしてください。

(4) 太字で表示したい場合は「太字で表示する」の□にチェックを入れます。

(5) 文字の色を全体でまとめて設定するか、個別に設定するかを決めます。
「通常状態の文字色を共通に利用する」の□にチェックを入れた場合は、次のようになります。

(6) 色を変更したい項目の色つきのボタンを選択して、「色の設定」画面を開きます。

メモ 「通常状態の文字色を共通に利用する」の□にチェックが入っている場合は、「文字色」は「通常状態」以外はボタンを押せません。

(7)「色の設定」画面で色を選択して「OK」を押します。

メモ マウス以外(パソコンのキーボードや、オペレートナビのオンスクリーンキーボード)で設定を行う場合は、選択する色の上で「スペース」キーを押してください。この操作をしないと、選択した色が反映されません。

設定する色がどの部分の色か、次の図で確認してください。

[目次に戻る]

3.6 オンスクリーンキーボードを追加する

オンスクリーンキーボードを追加登録する方法は、キーボードファイルを新規作成する以外に次のようなものがあります。

3.6.1 「KB切替」キーボードに表示する/しないを切り替える

オペレートナビには多くのオンスクリーンキーボードがありますが、すべてを「KB切替」キーボードに表示する必要はありません。
例えば、かな小文字入力用の「かな小」というキーボードは「かな」から呼び出して使うようにできており、「KB切替」キーボードでは非表示となっています。

「KB切替」キーボードへの表示/非表示は次のように行います。

(1)「オンスクリーンキーボード」を選択します。

(2)「登録キーボード」より"一覧表示"したいキーボードを選択します。

(3)「一覧表示」ボタンを押します。
「登録キーボード」一覧の「一覧表示」の列に「●」が付いているものが「KB切替」キーボードに表示されるオンスクリーンキーボードです。

3.6.2 非表示になっているキーボードをセットファイルに追加する

「3.7 不要なキーボードファイルを削除する」で「登録情報のみ削除」を選択した場合など、セットファイル内には実体があるが、「登録キーボード」一覧に表示されないキーボードが存在することがあります。このような場合は次の手順で使えるようにできます。

(1)「オンスクリーンキーボード」を選択します。

(2)「新規作成」ボタンを押して「新規作成方法選択」画面を表示します。

(3)「セット内のキーボードを参照」を選択して「OK」ボタンを押します。
「キーボード参照」画面にセットファイルに保存されているすべてのキーボードファイルが表示されます。

(4) 追加したいキーボードファイルを選択して「OK」を押します。

(5) 選択したキーボードファイルを読み込んで「キーボード編集」画面が開くので、メニューバーの「ファイル」→「上書き保存」を選択します。

(6)「キーボード編集」画面を閉じて終了です。

3.6.3 他のセットファイルや標準添付のセットファイルから取り込む

他のセットファイルからキーボードファイルをコピーして使用することができます。

(1)「オンスクリーンキーボード」を選択します。

(2)「標準取込」ボタンを押して「キーボード取込」画面を表示します。

(3)「標準キーボード一覧」または「別セットの登録済みのキーボード一覧」で、取り込みたいキーボードファイルの□にチェックを入れます。複数にチェックを入れることで、一度にまとめて複数のキーボードファイルを取り込むこともできます。

標準キーボード一覧
出荷初期状態のキーボードが表示されます。

別セットの登録済みのキーボード一覧
現在登録されているセットファイル名と、そのセットに現在登録されているキーボードが表示されます。オペレートナビTT3.5のインストール直後は「標準キーボード一覧」と同じ内容です。インストール後に編集を行ったキーボードファイルをコピーして使いたい場合は、こちらの一覧からキーボードを選択して下さい。

(4)「OK」ボタンを押すと、「キーボード取込」画面が閉じ、「登録キーボード」の一番下に取り込んだキーボードが追加されます。

3.6.4 他のPCで使っているキーボードファイルをコピーする

他のPCで使用しているキーボードファイルを圧縮ファイル形式で書き出し(エクスポート)、そのファイルを現在使用しているPCのセットファイルに書き込むことができます(インポート)。
この機能を使うとPCの交換や再セットアップ時のバックアップのほか、オペレートナビのユーザー間でキーボードファイルの交換をしたり、複数のPCに同じキーボードファイルを組み込むことができます。

[目次に戻る]

3.7 不要なキーボードファイルを削除する

使用していないキーボードを登録情報からはずすか、またはキーボードファイル自体を削除することができます。

(1)「オンスクリーンキーボード」を選択します。

(2)「登録キーボード」欄から、削除したいキーボードファイルを選びます。

(3)「削除」ボタンを押して「キーボード削除」画面を開きます。

(4) どの方法で削除するかを選択して「OK」ボタンを押します。

登録情報のみ削除
セットファイルから選択したキーボードの登録情報のみを削除して、「登録キーボード」一覧に表示しないようにします。キーボードファイル自体を削除するわけではないので、後から「3.6.2 非表示になっているキーボードをセットファイルに追加する」の手順で登録し直すこともできます。

参照しているキーボードを確認せずにファイル削除
選択したキーボードファイルを削除します。この作業を実行した後は、削除したファイルを元に戻すことはできません。

参照しているキーボードを確認
選択したキーボードが他のキーボードから呼び出し(参照)をしていないかどうか、事前にチェックすることができます。検索結果の画面から、登録情報のみ削除するか、ファイル自体を削除するかを再度選択できます。

[目次に戻る]

3.8 キーボードファイルの順番を変える

「KB切替」キーボードでの表示順を変更することができます。よく使うキーボードを上または左の方にくるように配置を調整するとよいでしょう。

(1)「オンスクリーンキーボード」を選択します。

(2)「登録キーボード」の中から順番を変えたいキーボードを選択します。

(3)「上へ移動」「下へ移動」ボタンを押すと、順番を上または下に1つずつ動かすことができます。

[目次に戻る]

3.9 オペレートナビが起動したときに開くキーボードを変更する

初期設定では、オペレートナビを起動した時には「AP起動」キーボードが開きますが、このキーボードを別のものに変更できます。

(1)「オンスクリーンキーボード」を選択します。

(2)「登録キーボード」欄でオペレートナビ起動時に開きたいキーボードファイルを選択します。

(3)「起動時設定」ボタンを押します。
選択したキーボードファイルの「起動時」の列に「●」印が表示されます。

メモ 起動時設定を解除する場合は「●」印のついているキーボードファイルを選んでもう一度「起動時設定」ボタンを押します。起動時設定になっているキーボードファイルがない場合は、「AP起動」キーボードが開きます。

[目次に戻る]

3.10 作成したキーボードファイルを別の環境で利用する(エクスポート)

キーボードファイルを圧縮ファイル形式で書き出し(エクスポート)、そのファイルを別のPCのセットファイルに書き込むことができます(インポート)。
この機能を使うとPCの交換や再セットアップ時のバックアップのほか、オペレートナビTTのユーザー間でキーボードファイルの交換をしたり、複数のPCに同じキーボードファイルを組み込むことができます。

ファイルを書き出す手順は次の通りです。

(1)「オンスクリーンキーボード」を選択します。

(2)「登録キーボード」の一覧から書き出したいキーボードを選択します。

(3)「エクスポート」を押します。

(4)「エクスポート」画面(ファイルダイアログ)で、保存する場所と書き出すファイルのファイル名を入力して「保存」ボタンを押します。

[目次に戻る]

3.11 別のPCで作成したキーボードファイルを読み込む(インポート)

エクスポートしたキーボードファイルを読み込むことができます。あらかじめ外部メディアに書き込んだり、PC同士をネットワーク接続するなどして、ファイルを読み込むPCから書き出したファイルにアクセスできるようにしておいて下さい。

(1)「オンスクリーンキーボード」を選択します。

(2)「インポート」ボタンを押します。

(3)「インポート」画面(ファイルダイアログ)で読み込むファイルの場所、ファイルを選択して「開く」ボタンを押します。

[目次に戻る]

3.12 今操作している部分を目立たせる

メニューやボタン、Internet Explorerのリンクなど、現在操作の対象になっている部分(フォーカス)を色付きの枠で囲んで強調表示をします。

フォーカス強調表示できるものには次の3種類があります。

ご注意 アプリケーションによってはフォーカス強調表示されないものがあります。

設定の手順は次の通りです。

(1)「フォーカス強調」を選択します。

(2)「フォーカス強調機能を利用する」の□にチェックを入れます。

(3) フォーカス強調表示を使用したい項目の「強調」の□にチェックを入れます。

メモ 「音声」の□にもチェックを入れると、フォーカス強調表示している部分を音声で読み上げます。

(4) フォーカス強調表示の枠の色を変更したい場合は、「強調色」の色のついたボタンを選択すると「色の設定」画面が開きます。この画面で色を選んで「OK」ボタンを押します。

[目次に戻る]

3.13 現在操作している内容を画面に表示させる

スイッチを押した時に、その操作内容(スイッチコマンド)を画面に表示させることができます。

インジケーター表示の設定手順は次の通りです。

(1)「インジケータ表示」を選択します。

(2)「インジケータ表示を利用する」の□にチェックを入れます。

(3)「表示位置」の▼を押してリストを開き、画面のどの位置に表示させるかを選びます。

(4) インジケーター表示に使用するフォントの設定をします。

(5)「文字色」「背景色」の右にある色のついたボタンを押して、それぞれの色を選択します。

(6)「表示時間」に、スイッチを押してから何秒間表示しておくか、という時間を入力します。

メモ スキャン入力設定で「押している時間で機能実行」を選択した場合は、スイッチ入力の「機能有効時間」とインジケーター表示の「表示時間」を合わせておくと、スイッチを離すタイミングが分かりやすくなります。

[目次に戻る]

3.14 よく使う文章を、素早く入力する(語句補完機能)

オペレートナビには、過去に入力したことのある語句を内部の辞書に記憶しておき、文字が入力された時にその文字で始まる語句を候補として表示させる語句補完という機能があります。候補の中に入力したい語句があれば、それを選択することで入力できるので、文章入力の時間を短縮できます。

3.14.1 語句補完機能を有効にする

語句補完機能を使えるようにします。

(1)「語句補完」を選択します。

(2)「語句補完を利用する」の□にチェックを入れます。

3.14.2 登録語句を新しく追加する

候補として表示される語句を、新規に登録します。
オペレートナビ設定で手作業で語句登録する方法と、オペレートナビで文字入力の際にIME変換確定語句を自動で登録する方法の2通りあります。

以下は、語句補完機能が有効になっている状態での説明です。

●手作業で登録する

(1)「語句補完」を選択します。

(2)「新規登録」ボタンを押して、「補完語句登録」画面を開きます。

(3) 登録したい語句とその読みを入力して、「登録」ボタンを押します。

●自動で登録する

(1)「語句補完」を選択します。

(2)「IME変換情報を自動的に登録する」の□にチェックを入れます。

メモ オペレートナビ操作中に「(オペナビ)メニュー」→「機能切替」キーボードの「IME変換情報自動登録」を切り替えることで、一時的に自動登録オン/オフにすることができます。

3.14.3 登録されている語句を編集・削除する

候補として表示される語句の内容(語句・読み)を編集したり、不要な語句が表示される場合にはそれを削除することができます。

(1)「語句補完」を選択します。

(2)「登録語句」の一覧で編集・削除したい語句を選択します。
語句が多くて見つけにくい場合は、「語句でソート」を押して文字コード順に、または「読みでソート」を押してと50音順にそれぞれ一覧を並べ直すと探しやすくなります。

(3)「編集」ボタンを押すと「補完語句編集」画面が開くので「語句」と「読み」の登録を変更します。
「削除」ボタンを押すと「補完語句削除」画面が開き、ここで「OK」ボタンを押すと選択した語句が削除されます。

メモ スコアについて
「登録語句」の一覧の一番右に「スコア」という項目があります。これは登録されている語句の利用頻度を示していて、文章入力の際にその語句を選択するほどスコアが上がり、補完語句候補の上の順位に表示されます。また、登録できる語句の数には上限があり、登録数が上限に達した際にはスコアの低い物から順に自動で削除していきます。

[目次に戻る]

3.15 IMEを自動で起動させる

メモ帳やワードパッドを起動したときに、自動的にIMEがオンになるように設定できます。

 

(1)「アプリケーション登録」を選択します。

(2)「IMEを自動的に有効にする」の□にチェックを入れます。

[目次に戻る]

4章 音

この章では「音声出力」「スキャン操作効果音」「読み上げ機能」「フォーカス強調(一部)」について説明します。

4.1 文章を読み上げる

文章などを合成音声で読み上げられるように設定します。

(1)「音声出力」を選択します。

(2)「音声出力を利用する」の□にチェックを入れます。

(3)「読み上げ機能」を選択します。

(4)「読み上げ機能の設定」の▼を押してリストを開き、「拡大表示なし」または「拡大表示あり」を選びます。

メモ 「拡大表示あり」を選んだ場合は、読み上げ中の文章を拡大して画面に字幕表示します。

[目次に戻る]

4.2 読み上げ箇所を拡大表示する

読み上げ中の文章を拡大して画面に字幕表示させることができます。

(1)「読み上げ機能」を選択します。

(2)「読み上げ機能の設定」の▼を押してリストを開き、「拡大表示あり」を選びます。

(3)「表示位置」の▼を押してリストを開き、画面のどこに表示させるかを選択します。

(4)「フォント」の▼を押してリストを開き、拡大表示に使用するフォントを選びます。

(5)「フォントサイズ」に表示させたい文字の大きさを入力します。

(6) 太字で表示したい場合は「太字で表示する」の□にチェックを入れます。

(7)「文字色」「背景色」の色のついたボタンを押して、それぞれに使用する色を選択します。

※ (4)〜(7)の操作の際は、「表示例」の画面を参考にしてください。

[目次に戻る]

4.3 操作時に音を鳴らす

スイッチを押したときやオンスクリーンキーボードでスキャンをしたときなどに、効果音をならしたり、合成音声で読み上げをしたりできます。
音を鳴らせるのは次のような場合です

また、グループスキャンとキースキャンで、別の設定をすることもできます。例えばグループスキャンのときには効果音を鳴らし、キースキャンのときは音声で読み上げるようなこともできます。

(1)「スキャン操作効果音」を選択します。

(2)「オンスクリーンキーボード操作時の設定」の□にチャックを入れます。

(3)「グループスキャン([移動時]/[選択時])」「キースキャン([移動時]/[選択時])」の各項目の▼を押してリストを開き、効果音を鳴らすか、読み上げをするか、もしくは何も鳴らさないかを選択します。

メモ 「録音ファイル/合成音声」を選んだ場合、キーボードファイル側で録音ファイルを鳴らすように設定されていれば録音ファイルを再生し、録音ファイルが設定されていない場合は合成音声でグループやキーの文字を読み上げます。

メモ テンキー操作の場合は、グループスキャンについては設定する必要はありません。キースキャンについてのみ設定してください。

(4)「効果音音量([移動時]/[選択時])」で各効果音を鳴らす際の音量を設定します。

(5) スイッチを押したときに音を鳴らす場合は、「スイッチ操作時の効果音を出力する」の□にチェックをれ、「効果音音量」で音量を設定します。

[目次に戻る]

4.4 最後まで読み上げてからスキャンを移動する

「録音ファイル/合成音声」を選んだ場合、合成音声による読み上げが完全に終了してからスキャンが移動するか、一定のスキャン速度で移動するかを設定できます。

 

(1)「録音ファイル/合成音声」を選択します。

(2)「読み上げ完了後移動([移動時]/[選択時])」の▼を押してリストを開き、項目を選択します。
「両方実施しない」を選択した場合は読み上げの途中でもスキャンが移動するようになります。

[目次に戻る]

4.5 音声でフォーカス位置を読み上げる

メニューやボタン、またはInternet Explorerのリンク部分等、現在操作の対象になっている部分(フォーカス)に書かれている文字を合成音声で読み上げます。
読み上げできるものには次の3種類があります(ただしアプリケーションによっては読み上げられないものがあります)。

設定の手順は次の通りです。

(1)「フォーカス強調」を選択します。

(2)「フォーカス強調機能を利用する」の□にチェックを入れます。

(3) 読み上げさせたい項目の「音声」の□にチェックを入れます。

[目次に戻る]

4.6 読み上げを聞きやすくする(速度や声質の調整をする)

合成音声による読み上げの速度や音程、声質等を変更できます。

(1)「音声出力」を選択します。

(2)「音声出力を利用する」の□にチェックを入れます。

(3)「声の種類」の▼を押してリストを開き、「男性」または「女性」を選択します。

(4)「速度」「音量」「音程」にそれぞれ数値を入力します。

(5)「数字を桁読みする」の□にチェックを入れると、例えば「123」を「ヒャクニジュウサン」と読みます。このチェックをはずした場合は「イチニサン」と読みます。

(6)「音声出力テスト」に適当な言葉を入力し「テスト再生」ボタンを押すと、実際にどんな声になるか試すことができます。

[目次に戻る]

4.7 特殊な読みを登録する

キーや文書の読み上げのときに、おかしな読み上げをする、またはあえて違う読み方をさせたいような場合には、新しい読み方を登録することができます。

(1)「音声出力」を選択します。

(2)「音声出力を利用する」の□にチェックを入れます。

(3)「ユーザ辞書編集」ボタンを押します。
「読み上げ用単語編集」画面が開きます。

(4)「追加」ボタンを押します。
「単語登録」画面が開きます。

(5)「単語」欄に登録したい単語を入力します。

(6)「読み」欄に登録したい読み方を入力します。

(7)「OK」ボタンを押します。

メモ 間違えて登録してしまった場合は、一覧で登録した単語を選び、「削除」ボタンを押して削除するか、「修正」ボタンを押して「読み」を修正することができます。

[目次に戻る]

4.8 登録した読み方を変更する

読み上げ用単語を編集することができます。

(1)「読み上げ用単語編集」画面を開きます。

(2) 一覧で編集したい単語を選びます。
登録されている単語が多くて目的の単語を見つけにくい場合は、「単語でソート」を押して文字コード順に、または「読みでソート」を押してと50音順にそれぞれ一覧を並べ直すと探しやすくなります。

(3)「修正」ボタンを押して「単語編集」画面を開きます。

(4)「読み」の内容を消し、新しい読みを入力します。

(5)「OK」ボタンを押します。

[目次に戻る]

4.9 読み上げ用ユーザ辞書をコピーする

読み上げ用ユーザ辞書を別ファイルとして書き出すことができます。

書き出したファイルは再度読み込ませることができるので、オペレートナビを再セットアップしたとき辞書を作り直す手間が省けたり、ほかのユーザーの環境に辞書をコピーすることができます。

(1)「読み上げ用単語編集」画面を開きます。

(2) ファイルを書き出す場合は「エクスポート」を押し、開いた画面で保存先を選択して「保存」を押します。

(3) ファイルを読み込む場合は「インポート」を押し、開いた画面で(2)で書き出したファイルを選択し、「開く」を押します。

[目次に戻る]

5章 マウスポインタ

この章では「ポインタ設定」「スキャン方法(一部)」について説明します。

5.1 移動の速さを変更する

オペレートナビからマウス操作をする場合の、マウスポインタの移動速度を設定します。

(1)「ポインタ設定」を選択します。

(2)「移動速度[低速時]」に、初めに動き出すときの移動速度を入力します。

(3)「移動速度[高速時]」に、速く動くときの移動速度を入力します。

[目次に戻る]

5.2 長く移動する場合は速さを変える

オペレートナビではマウスポインタを移動させる場合、まずゆっくり動き出し一定時間が経過すると速く動くようになります。ここでは、高速移動に切り替わる時間を設定します。

(1)「ポインタ設定」を選択します。

(2)「移動速度変化時間」に、何秒たったら速く動かすか、という時間を入力します。

メモ マウスポインタの移動速度を変えずに、いつも同じ速度で動かしたい場合は、「移動速度[高速時]」に「移動速度[低速時]」と同じ数を入力します。

[目次に戻る]

5.3 マウスポインタが自動で止まるまでの時間を変更する

オペレートナビでは、マウスポインタが移動を始めてから一定時間が経過すると移動が止まります。ここではポインタの移動が止まるまでの時間を設定します。

(1)「ポインタ設定」を選択します。

(2)「自動停止時間」に、何秒たったらマウスポインタが止まるか、という時間を入力します。

[目次に戻る]

5.4 画面端での動作を変更する

マウスポインタが移動して、画面の一番端に行ったときに、どのように動くかを選択します。

(1)「ポインタ設定」を選択します。

(2)「画面の端」の▼を押してリストを開き、「折り返し/停止」または「反対に抜ける」を選択します。

[目次に戻る]

5.5 移動の方向を変更する

オンスクリーンキーボードからのマウス操作や画面スキャンなどスイッチを使ったマウス操作で、マウスポインタの移動方向を決めるときの、方向選択の移動速度(赤いが何秒間隔でマウスポインタの周りを回るか)や回数(赤いが何周するか)を設定します。
テンキー操作のマウスエミュレーションの場合は関係ありません。

●スキャン速度と同じにする場合

(1)「ポインタ設定」を開きます。

(2)「キーボードスキャン設定に準じる」の□にチェックを入れます。

●スキャン速度とは違う設定にしたい場合

(1)「ポインタ設定」を開きます。

(2)「キーボードスキャン設定に準じる」の□のチェックをはずします。

(3)「方向切替間隔」で、マウス方向インジケーター()の回転速度を入力します。

(4)「方向切替回数」で、マウス方向インジケーター()の最大回転数を入力します。

[目次に戻る]

5.6 マウスポインタをみつけやすくする

マウスポインタの周りに色のついたリングを表示させ、マウスポインタの位置が分かりやすいように強調表示させることができます。

(1)「ポインタ設定」を選択します。

(2)「マウスポインタを強調する」の□にチェックを入れます。

(3)「強調色」の右にある色のついたボタンを押して、開いた場面で強調表示のリングの色を選択します。

[目次に戻る]

5.7 ジャンプ位置を登録する

画面スキャンモード(オンスクリーンキーボードを使わずに、スイッチで直接マウス操作をする方法)でマウスポインタを指定した位置にジャンプさせるためのジャンプ位置を登録します。

メモ オンスクリーンキーボードによる操作のジャンプ位置は、各キーボードファイルごとに設定されるので、ここでの設定は関係ありません。画面スキャンモードを使用しない場合はこの設定は必要ありません。

(1)「スキャン方法」を選択します。

(2)「画面スキャンを利用する」の□にチェックを入れます。

(3)「ジャンプ位置設定」ボタンを押します。
「ジャンプ位置一覧」画面が開きます。

(4)「座標A〜J」の中から1つを選びます。

(5)「位置設定」ボタンを押します。
「ジャンプ位置設定」画面が開きます。

(6)「基準位置」の▼を押してリストを開き、基準位置を選択します。

メモ 基準位置とは?
ジャンプ位置を登録する場合、ある点から登録したいジャンプ位置までの距離を測り、その数値を登録しますが、その「ある点」が基準位置です。
「画面○○」というのはパソコンの画面全体に対しての位置、「ウィンドウ○○」というのは現在操作しているアプリケーションのウィンドウの中での位置になります。特定のウィンドウの中にあるボタン等にジャンプさせたい場合はウィンドウ基準を選択してください。
また、ウィンドウのサイズや画面の解像度を変えても、ジャンプ位置が変わらないものを選んでください。

(7) 基準位置から目的の位置までの距離(単位はドット)が分かっている場合は、「横」「縦」にそれぞれ数値を入力します。分かっていない場合は「マウスで設定」ボタンを押し、画面の指示に従ってジャンプさせたい場所を直接マウスでクリックします。

[目次に戻る]

6章 オンスクリーンキーボード

この章ではオンスクリーンキーボードの「キーボード編集」機能について説明します。

● キーボードファイル

オンスクリーンキーボードの各キーに表示される文字や、キーを押したときに実行される機能などは、「キーボードファイル」というファイル(拡張子"kbd")に記録されています。
キーボードファイルはオペレートナビ設定の「キーボード編集」機能で作成・編集します。

●「キーボード編集」画面への切り替え

キーボード編集機能の中心となる「キーボード編集」画面へは、「オペレートナビ設定」の左の画面で「オンスクリーンキーボード」を選んだ画面から、次のような方法で移動します。

(1) キーボードファイルを新規に作成する
「新規作成」ボタンを押して「新規作成方法選択」画面を開き、画面の指示に従います。
詳細は「6.1 オンスクリーンキーボードを作る(操作の手順)」を参照して下さい。

(2) 既存のキーボードファイルを編集する
「登録キーボード」画面にセットファイルに登録されているキーボードが一覧表示されているので、その中から設定を変更したいキーボードを選択し、「編集」ボタンを押します。

●「キートップ設定」画面の開きかた

「キートップ設定」では、オンスクリーンキーボードに表示させる文字や絵を設定できます。
「キートップ設定」画面を開くには、次のような方法があります。

●「操作列設定」画面の開きかた

「操作列設定」では、そのキーを選択したときに実行される機能を設定できます。
「操作列設定」画面を開くには、次のような方法があります。

●IMEオンの選択

「キーボード編集」でキートップの名前等を入力する際に、自動的にIMEオンにするかどうかを設定できます。

(1)「キーボード編集」画面を開きます。

(2) メニューバーの「ツール」→「自動的にIMEをONにする」にチェックがついているかを確認します。ついている場合は有効、ついていない場合は無効です。
切り替えたい場合は「自動的にIMEをONにする」を選択します。

[目次に戻る]

6.1 オンスクリーンキーボードを作る(操作の手順)

オンスクリーンキーボードを作成する手順の概要は次のようになります。
まったく新しいキーボードファイルを作成する場合と、既存のファイルに追加・修正をする場合で、多少手順が異なります。

●新規作成の場合の概要手順

(1)「オンスクリーンキーボード」を選択します。

(2)「新規作成」ボタンを押して「新規作成方法選択」画面を開きます。

(3)「ウィザードで作成」を選択して「OK」を押します。
「キーボードファイル新規作成」画面が表示されます。

(4) 作成するキーボードの縦横のキーの数を入力して「OK」ボタンを押すと、「キーボード編集」画面が開きます。キーの数は後から変更することもできます。

(5) 各キーを選択してキートップと操作の内容を登録します。

(6) グループ(スキャンをするときの複数のキーの集まり)を設定します。

(7) オンスクリーンキーボードの大きさなどを見やすいように修正します。

(8) 登録したキーボードファイルをアプリケーションと関連付けて、特定のアプリケーションが起動したときに自動でそのキーボードに切り替わるようにします。

(9) メニューバーの「ファイル」→「名前を付けて保存」を選択して、作成したキーボードファイルに名前を付けて保存します。

●標準添付のキーボードを元に編集する場合の概要手順

(1)「オンスクリーンキーボード」を選択します。

(2)「新規作成」ボタンを押して「新規作成方法選択」画面を開きます。

(3)「標準キーボードから作成」を選択して「OK」を押します。
「標準キーボードから作成」画面が表示されます。

(4)「標準キーボード一覧」または「別セットの登録済みのキーボード一覧」で、元にして編集したいキーボードファイルを選択して「OK」ボタンを押します。各一覧に表示されているのはインターフェイスセット名で、その左にある「+」ボタンを押すと、そのセット内のキーボードが表示されます。

(5) 必要に応じてキーの数を増やします。

(6) キーを選択してキートップと操作の内容を登録します。

(7) 不要なキーを削除します。

(8) グループ(スキャンをするときの複数のキーの集まり)を設定します。

(9) メニューバーの「ファイル」→「名前を付けて保存」を選択して、編集したファイルを保存します。

●現在のセットで使用中のキーボードファイルを編集する場合の概要手順

(1)「オンスクリーンキーボード」を選択します。

(2)「登録キーボード」の一覧で、編集するキーボードを選択します。

(3)「編集」ボタンを押して「キーボード編集」画面を開きます。

(4) 必要に応じてキーの数を増やします。

(5) キーを選択してキートップと操作の内容を登録します。

(6) 必要に応じて不要なキーを削除します。

(7) グループ(スキャンをするときの複数のキーの集まり)を設定します。

(8) メニューバーの「ファイル」→「名前を付けて保存」または「上書き保存」を選択して、編集したファイルを保存します。

[目次に戻る]

6.2 キーボードファイルを使用するアプリケーションに関連付ける

キーボードファイルとアプリケーションを関連付けることで、特定のアプリケーションを起動したときに自動でオンスクリーンキーボードを切り替えることができ、「KB切替」から切り替える手間が省けます。特定のアプリケーションを操作するための専用キーボードを作った場合には、この設定をしておくと便利です。

注意 Windowsストアアプリ(モダンUI)との関連付けは行えません。

関連付けの具体的な動作は、起動した(切り替わった)アプリケーションのタイトルバー(下図参照)に、登録した語句が含まれている場合はそのキーボードに切り替える、というもので、ここではそのための語句を登録します。複数のキーボードに同じ言葉を登録しないように気をつけてください。


設定の手順は次の通りです。

(1) 関連付けをしたいアプリケーションを起動しておきます。

(2) 関連付けしたいキーボードの「キーボード編集」画面を開きます。

(3)「キーボード編集」画面でメニューバーの「ツール」→「対応ウィンドウ設定」を選択します。
「対応ウィンドウ設定」画面が開きます。

(4)「現在起動中のウィンドウ」欄で(1)で起動したアプリケーションのウィンドウを選択して「編集して追加」ボタンを押します。「対応ウィンドウ名編集」画面が開きます。

(5) 不要な部分を削除して、「OK」ボタンを押します。

メモ タイトルバーの表示が「○○○ - △△△」のようになっている場合、「△△△」の部分がアプリケーション名で、アプリケーションで開いているファイル名を示す「○○○」の部分は必要ありません。
例えば「1スイッチスキャン - オペレートナビ設定」を選んだ場合、「1スイッチスキャン - 」の部分を削除しないと、"1スイッチスキャン(.ope)" 以外のファイルを開いているときは、オペレートナビ設定を起動してもキーボードが切り替わらなくなってしまいます。

(6)「このキーボードに設定されている対応ウィンドウ」の欄に登録されていることを確認します。

メモ タイトルバーに表示されるアプリケーション名が最初から分かっている場合は、(4)で「編集して追加」ではなく「新規追加」ボタンを押し、表示される画面でアプリケーション名を入力してもかまいません。
その場合はカタカナの全角/半角にご注意下さい。

メモ 関連付けを設定し直す場合は、「このキーボードに設定されている対応ウィンドウ」欄で不要な物を選択し、「削除」ボタンを押して一覧から消してから設定を行って下さい。

[目次に戻る]

6.3 行列数を増やす

既存のキーボードファイルのキーを追加・削除するときなど、キーボードのキーの数を行・列単位で変更できます。

(1)「キーボード編集」画面のメニューバーの「ツール」→「キーボードサイズ設定」を選択します。
「サイズ変更」画面が開きます。

(2)「キーの数」で縦・横のキーの数を入力します。
「サイズ変更」画面が開いたときに表示されている数が現在の縦・横のキーの数です。
この数を増やした場合はその分だけ右、または下に行・列が追加されます。
この数を減らした場合はその分だけ右、または下から行・列が削除されます。削除された行・列に操作を登録したキーがある場合は、その設定内容も消えてしまいますので注意してください。

[目次に戻る]

6.4 表示サイズを変更する

各キーの名前が全部表示されるようにオンスクリーンキーボードを大きくする、オンスクリーンキーボードがアプリケ−ションの操作の邪魔になるので小さくするなど、オンスクリーンキーボードのサイズを変更します。

サイズを変更する方法はいくつかあります。

●数値を入力して変更する

(1)「キーボード編集」画面のメニューバーの「ツール」→「キーボードサイズ設定」を選択してます。
「サイズ変更」画面が開きます。

(2)「サイズ」で、縦・横のキーボードのサイズをドット単位で入力します。

●オンスクリーンキーボードの大きさを直接変える

(1) オペレートナビを起動します。

(2) サイズを変更したいキーボードに切り替えます。

(3) オンスクリーンキーボードの端の部分をマウスでドラッグするか、「(オペナビ)メニュー」→「オペナビウィンドウ操作」キーボードの「サイズ変更」で大きさを変えます。

[目次に戻る]

6.5 大きなボタンを作る

複数のセルを連結して、一つの大きなキーにすることもできます。

(1) 連結したい隣り合う複数のキーを選択します。
複数のキーは、次のような方法で選択します。

(2)選択したキーの上で右クリックまたはメニューバーの「編集」のメニューで、「連結設定」を選びます。

メモ 元に戻す場合は同じ手順で「連結解除」を選びます。

メモ 複数選択したキーの中で一番左、上にあるキーの設定内容が連結されたキーの内容になります。
右、下になるキーの設定は消えてしまいますので注意してください。

[目次に戻る]

6.6 キーのレイアウト(位置)を変更する

よく使うキーをグループの先頭にするなど、キーボードの中でキーの位置を変更できます。

(1) レイアウト変更したいキーを選び、右クリックまたはメニューバーの「編集」のメニューで「切り取り」を選びます。

(2) 移動先のキーを選び、右クリックまたはメニューバーの「編集」のメニューで「貼り付け」を選びます。

[目次に戻る]

6.7 キーボードの縦・横を入れ替える

キーボードの縦・横のサイズと配列、およびスキャンの方向を入れ替えます。
例えば縦長で上からスキャンするキーボードは、横長で左からスキャンするようになります。

メモ 右からスキャンするキーボードを作るには別の設定が必要になります。 詳しくは「6.27 スキャンの際のグループを設定する」を参照してください。

(1) メニューバーの「編集」→「行列入れ替え」を選びます。

[目次に戻る]

6.8 キーに表示する名前を登録する

オンスクリーンキーボードのキーに表示させる文字を登録できます。

(1)「キーボード編集」画面でキーを選択して「キートップ設定」を開きます。

(2)「文字のみ」を選択します。

(3)「文字表示」にキートップに表示する文字を入力します。

[目次に戻る]

6.9 キーに絵を表示させる

オンスクリーンキーボードのキーに画像を表示させることができます。

(1)「キーボード編集」画面でキーを選択して「キートップ設定」を開きます。

(2)「画像のみ」を選択します。

(3)「画像ファイル名」の「参照」ボタンを押し、表示したい画像ファイルを選びます。
選択できる画像形式はBMP及びJPG形式です。

(4)「型抜き(縁取り)する」の□にチェックを入れると、選択した画像の左上の色を透明とみなして、その画像の中の同じ色をすべてキーボードの背景色と同じに表示します。

[目次に戻る]

6.10 ボタンに説明を添える(絵と文字両方を表示させる)

オンスクリーンキーボードのキーに、画像と文字の両方を表示させることができます。

(1)「キーボード編集」画面でキーを選択して「キートップ設定」を開きます。

(2)「画像+文字(右)」または「画像+文字(下)」を選択します。

(3)「文字表示」に表示させる文字を入力します。

(4)「画像ファイル名」の「参照」ボタンを押し、表示したい画像ファイルを選びます。

(5) 型抜きをする場合は「型抜き(縁取り)する」の□にチェックを入れます。

[目次に戻る]

6.11 キーの読み上げの際の名前を登録する

キーがスキャンされたときや、キーを選択したときに読み上げる言葉を登録できます。

(1)「キーボード編集」画面でキーを選択して「キートップ設定」を開きます。

(2) キートップに表示されている文字をそのまま読み上げる場合は、「表示文字」を選択します。

(3) 表示文字と読み上げを別にしたい場合は、「読み上げ文字」を選択し、「読み上げ文字」欄に読み上げる文字を入力します。

[目次に戻る]

6.12 キーの読み上げに、録音音声を使う

キーの読み上げには、登録した文字(文章)を合成音声で読み上げるほかに、録音音声などの音声ファイルを登録して、それを再生することもできます。

(1)「キーボード編集」画面でキーを選択して「キートップ設定」を開きます。 

(2)「読み上げ」の「録音ファイル」を選択します。

(3)「録音ファイル名」の「参照」ボタンを押し、音声ファイルを選びます。
選択できるファイル形式はWAV形式のみです。

[目次に戻る]

6.13 同じキーを連続して選択できるようにする

通常はキーを選択実行すると、キーボードの先頭からのスキャンになりますが、キーを選択実行しても、しばらく同じキーの上で点滅して、何度も同じキーを選択できるように設定できます。

(1)「キーボード編集」画面でキーを選択して「キートップ設定」を開きます。

(2)「連続入力に設定する」の□にチェックを入れます。

[目次に戻る]

6.14 ほかのキーと違う色やフォントのキーを作る

キーボードの中で、特定のキーだけ背景色やフォントの種類・大きさなどを変えることができます。

色やフォントの設定はキーごとの設定、キーボードごとの設定(「6.35 特定のキーボードだけ色やフォントを変更する」参照)、全体の設定(「3.5 配色や文字の大きさを変更する」参照)の順に優先されます。

(1)「キーボード編集」画面でキーを選択して「キートップ設定」を開きます。

(2)「フォント・配色設定を個別設定する」の□にチェックを入れます。

(3)「配色設定」ボタンが押せるようになるので、このボタンを押して「キートップ配色」画面を開きます。

(4)「フォント」の▼を押して、使用するフォントを選択します。

(5)「フォントサイズ」で表示させる文字のサイズを指定します。
太字にしたい場合は「太字で表示する」の□にチェックを入れます。

(6)「文字色」「背景色」のそれぞれの色の付いた□を押し、開いた画面で色を選択します。

(7)「OK」ボタンを押します。

[目次に戻る]

6.15 キーを押したときの動作を登録する

そのキーを押したときにどんな操作が実行されるかを設定します。キーボードやマウスによる操作のほかに、一例として次のような操作も登録できます。

なお、キーボードやマウスによる操作(複合操作列)の設定及びアプリケーションの起動については「6.16アプリケーションを起動する」、「6.17 キーボードやマウスを使う操作を登録する」で説明します。

(1)「キーボード編集」画面でキーを選択して「操作列設定」を開きます。

(2) 設定する項目を選びます。

(3) 選んだ項目の▼を押してリストを開き、登録したい操作を選びます。

[目次に戻る]

6.16 アプリケーションを起動する

「AP起動」キーボード以外からでも、キーを登録すればアプリケーションを起動できます。

(1) まず、起動させたいアプリケーションをオペレートナビ設定の「アプリケーション登録」に追加しておきます。

(2)「キーボード編集」画面でキーを選択して「操作列設定」を開きます。

(3)「アプリケーション」を選択し、▼を押してリストを開きます。

(4) 起動したいアプリケーションを選びます。

[目次に戻る]

6.17 キーボードやマウスを使う操作を登録する

キーボードやマウスを使った操作をキーに登録します。
「あ」と入力するとか、マウスでクリックするといった単純な操作だけではなく、長い文章を1回のキー選択で入力したり、キーボードとマウスを組み合わせた複雑な操作を設定することもできます。

ここでは「複合操作列設定」の流れについて説明し、詳細については「6.18」〜「6.26」で説明します。

(1)「キーボード編集」画面でキーを選択して「操作列設定」を開きます。

(2)「複合操作列」を選び「編集」ボタンを押します。
「複合操作列編集」画面が開きます。

(3)「操作選択」の中から設定する項目を選びます。

(4) 選択した項目の内容を入力または選択し「操作列挿入」ボタンを押します。

(5) 間違えた内容を挿入してしまった場合は次の方法で削除できます。

(6) 登録した操作内容を「複合操作列」欄で確認し、問題がなければ「OK」ボタンを押します。

<Q&A>

キーボードやマウスを使った操作をキーに登録するのはどのように便利なのですか?

「英数」や「マウス」キーボードだけでもアプリケーションの操作はできますが、よく行う一連の操作をキーに登録しておくと、使い勝手が向上します。

[目次に戻る]

6.18 よく使う文章を、1回のキーの選択で入力する

1回のキー選択で、文章を入力、または読み上げさせることができます。

(1)「キーボード編集」画面でキーを選択し、「操作列設定」→「複合操作列編集」を開きます。

(2)「文字」を選びます。

(3) 文字(文章)を入力します。

[目次に戻る]

6.19 指定したオンスクリーンキーボードに切り替える

「KB切替」キーボード以外からでも、指定したキーボードに切り替えることができます。

(1)「キーボード編集」画面でキーを選択して、「操作列設定」→「複合操作列編集」を開きます。

(2)「キーボード」を選びます。

(3) ▼を押してリストを開き、キーボードファイルを選択します。

[目次に戻る]

6.20 音声ファイルを再生する

キーを選択したとき、音声ファイルを再生することができます。

(1)「キーボード編集」画面でキーを選択して、「操作列設定」→「複合操作列編集」を開きます。

(2)「音再生」を選び「参照」ボタンを押します。「ファイルを開く」画面が開きます。

(3) 再生させる音声ファイルを選びます。(再生できるのはWAV形式の音声ファイルのみです。)

メモ 1回のキー選択で特定の音声ファイルを連続的に鳴らし続けたい場合は、「操作列設定」→「オペナビ操作」を選択し、リストより「BEEP.WAVを鳴らす」を選択します。
標準の音声ファイル以外を再生させたい場合は、以下のフォルダに同じファイル名(BEEP.WAV)で保存してください。ただし、その際に上書き保存すると元のBEEPファイルは消えてしまいますので、必ずファイルのバックアップをとってください。
(32ビットWindowsの場合) c:\Program Files\ttools\OpeNavi\TT\Bin\Sound
(64ビットWindowsの場合) c:\Program Files (x86)\ttools\OpeNavi\TT\Bin\Sound

[目次に戻る]

6.21 マウスによる操作を登録する

マウスの移動やボタン操作などをキーに登録することができます。

(1)「キーボード編集」画面でキーを選択して、「操作列設定」→「複合操作列編集」を開きます。

(2)「マウス」を選び「マウス操作」ボタンを押します。「マウス操作編集」画面が開きます。

(3)「操作選択」の中から設定する項目を選びます。

(4) 選択した項目の▼を押してリストを開き、登録したい操作を選びます。

(5)「操作挿入」を押します。

(6) 間違えた内容を挿入してしまった場合は次の方法で削除できます。

[目次に戻る]

6.22 距離を指定してマウスポインタを動かす

マウスポインタを指定した距離で移動させることができます。
「6.21 マウスによる操作を登録する」のジャンプ操作で、特定の位置にマウスポインタをジャンプさせた上で、距離を指定して更に移動させるといったことをすると、ジャンプ位置の登録数を抑えることができます。また、等距離ずつマウスポインタを移動させるといった操作もできます。

(1)「キーボード編集」画面でキーを選択して、「操作列設定」→「複合操作列編集」→「マウス操作編集」を開きます。

(2)「ポインタ移動[距離指定]」を選びます。

(3) 縦、横に何ドット移動するかを入力します。
縦:正の数字は下方向、負の数字は上方向へ移動します。
横:正の数字は右方向、負の数字は左方向へ移動します。

※ 距離(ドット数)のはかり方

距離を測るには、次のような方法があります。

  1. 距離をはかりたい画面を表示させます。
  2. PrintScreenキーを押して、スクリーンショットをとります。
  3. Windows標準の「ペイント」アプリを起動します。
  4. メニュー「ホーム」→「貼り付け」を選びます。
    スクリーンショットが貼付けされます。
  5. メニュー「表示」→「グリッド線」を選択します。
    ここで表示される、ます目1つが1ドットなので、移動したい距離のます目の数を数えます。
[目次に戻る]

6.23 画面に残った残像を消す

マウスポインタの移動などを行った際に、マウスを強調しているリングの跡などが残ってしまうことがあります。マウス操作を設定したキーを実行したときにこのような表示が残ってしまうときは、そのキーの操作内容の最後に次の操作を追加することで、それらの残像を消すことができます。

(1)「キーボード編集」画面でキーを選択して、「操作列設定」→「複合操作列編集」→「マウス操作編集」を開きます。

(2)「その他」を選びます。

[目次に戻る]

6.24 キーボードによる操作を登録する

キーボードによるキー操作を登録できます。
設定画面に表示される一覧からキー操作を選んで登録する方法と、ご支援者の方が直接パソコンのキーボードから入力して登録する方法の2通りがあります。

●一覧から選択する

(1)「キーボード編集」画面でキーを選択して、「操作列設定」→「複合操作列編集」を開きます。

(2)「キーコード」を選択します。

(3)「キー操作」ボタンを押して「キー操作編集」画面を開きます。

(4) 登録したいキーを選んでから「操作挿入」ボタンを押します。

(5) Shift、Ctrl、Alt、Windowsキーを一緒に押す操作を登録したい場合は、一緒に押すキーの□にチェックを入れてから(4)の操作を行います。(複数のキーにチェックを入れることも可能です。)

(6) 間違えた内容を挿入してしまった場合は次の方法で削除できます。

●直接キーボードから入力する

(1)「キーボード編集」画面でキーを選択して、「操作列設定」→「複合操作列編集」を開きます。

(2)「キーコード」を選択します。

(3)「直接打鍵入力」ボタンを押して「直接打鍵入力」画面を開きます。

(4)「入力」ボタンをマウスでクリックします。「入力」ボタンの表示が「終了」に変わります。

(5) 登録したい操作をパソコンのキーボードから行います。
入力した内容が画面に順に入力されていくので、内容を確認します。

(6) キーボードからの入力が終わったら「終了」ボタンをマウスでクリックします。

(7) 間違えた内容を挿入してしまった場合は次の方法で削除できます。

(8)「OK」ボタンを押すと、入力した内容が複合操作列に反映されます。

メモ 「Windows」キーや「Alt + Tab」など、一部のキーまたはキーの組み合わせでは、うまく入力されないものがあります。直接打鍵入力でうまく入力できなかった場合は、「●一覧から選択する」を参照して「キー操作編集」画面で入力してください。

[目次に戻る]

6.25 繰り返し操作を登録する

特定の操作を指定回数繰り返す(リピート入力)といった設定も行えます。

(1)「キーボード編集」画面でキーを選択して、「操作列設定」→「複合操作列編集」を開きます。

(2) 繰り返したい操作を登録します。

(3)「複合操作列」欄で繰り返したい操作を選択します。
マウスでドラッグするか、「Shift + 方向キー」で連続する複数の操作をまとめて選択することも可能です。

(4)「繰り返し設定」ボタンを押して「繰り返し設定」画面を開きます。

(5)「回数」欄に操作を繰り返す回数を入力します。

(6)「間隔」欄に何秒間隔で繰り返すかを入力します。
繰り返しの間隔をオンスクリーンキーボードのスキャンの間隔と同じにする場合は「スキャン間隔に準ずる」の□にチェックを入れます。(この場合は入力した間隔は無効になります。)

メモ マウスのクリック操作に対して繰り返しの操作を入れると、2回クリックのつもりがダブルクリックになってしまうような場合がありますのでご注意ください。

[目次に戻る]

6.26 操作間の待ち時間を登録する

複数の操作を実行する際に、タイミングによっては後続の操作が無視されてしまうことがあります。このような場合に「ポーズ(待ち時間)」を挿入すると改善されることがあります。

(1)「キーボード編集」画面でキーを選択して、「操作列設定」→「複合操作列編集」を開きます。

(2)「複合操作列」欄で、2つの操作のうち、後に実行する操作を選択します。
例えば、操作1、操作2が登録されていて、操作1と2の間に待ち時間を入れたい場合は、操作2を選択します。

(3)「ポーズ」を選択します。

(4) 待ち時間を入力します。
まずは0.5秒程度に設定し、結果を見て調整してみることをお勧めします。

[目次に戻る]

6.27 スキャンの際のグループを設定する

各キーの操作内容の設定が終わったら、グループの設定を行います。

ここで設定するグループは登録したキーの集まりで、オンスクリーンキーボードをスキャンするときの単位になります。(そのため、テンキーでご利用の場合にはこの設定は必要ありません。)

また、ここで設定するグループの順番が、スキャンの際の順番になります(上のグループから順番にスキャンします)。そこで、例えば右からスキャンするキーボードを作りたい場合は、右にあるグループを、左の画面では上に来るようにならべます。

ここでは「かな」キーボードのグループ設定をするときの画面を例に説明します。

●グループを作成する

(1)「キーボード編集」画面のメニューバーの「ツール」→「グループ設定」を選択します。
「キーボードグループ編集」画面が開きます。

(2) 左の画面で「ルートグループ」を選択して、右クリックまたはメニューバーの「編集」のメニューから「グループ作成」を選択します。「グループ名設定」画面が開きます。

(3)「グループ名」欄にグループ名を入力します。
オンスクリーンキーボードのスキャン時に音声で読み上げるように設定している場合は、ここで入力したグループ名を合成音声で読み上げます。この読み上げを、あらかじめ用意した録音ファイルで行いたい場合は、「読み上げに録音ファイルを使用する」の□にチェックを入れ、「録音ファイル名」の「参照」ボタンを押して録音ファイル(WAV形式)を選択します。

(4) (2)(3)を繰り返して1階層目のグループを設定します。

(5) グループの下に更にグループを作成する(親グループの下に子グループを設定する)場合は、左の画面で設定したい親グループを選択して、右クリックまたはメニューバーの「編集」のメニューから「グループ作成」を選択します。更に下層にグループを作成する場合も同様です。

●グループにキーを登録する

(1) 左の画面でキーを登録するグループを選択します。

(2) 右の画面で、(1)で選択したグループに登録するキーを選択します。
行、列単位でまとめて登録する場合は、行選択、列選択ボタンを押します。

メモ 古いバージョンのオペレートナビでは、下の階層にあるグループにキーを登録するにはまず上の階層のグループに登録する必要がありましたが、オペレートナビEX(Ver2.0)以降は、一番下のグループに登録するだけでよくなりました。例えば「アカサタナ」グループの下にある「アイウエオ」グループに「あ」「い」「う」「え」「お」の各キーを登録する場合、古いバージョンではまず「アカサタナ」グループに登録した上で「アイウエオ」グループに登録しましたが、オペレートナビEX(Ver2.0)からは「アイウエオ」グループに登録するだけでよくなりました。

(3) 右クリック、またはメニューバーの「編集」のメニューから「グループ登録」を選択します。

(4) (1)〜(3)を繰り返して、すべてのキーをグループに登録します。
登録しなかったキーはスキャンされません。

(5) メニューバーの「ファイル」→「キーボード編集に戻る」を選択して、「キーボード編集」画面に戻ります。

●グループの設定を編集する

右クリック、またはメニューバーの「編集」のメニューで上に出てきていないものについて説明します。

・グループ削除
間違って作成してしまったり、既存のキーボードファイルの編集中にいらなくなったグループを削除します。
グループを選択した状態で実行すると、選択したグループが削除され、登録されていたキーは未登録の状態になります。
・グループ名変更
設定されているグループ名を変更します。
グループを選択した状態で実行すると、「グループ名設定」画面が開きます。
操作方法は、グループを新しく作成するとき(「●グループを作成する」の(2)(3))と同じです。
・グループ順序上・下
グループの順番を入れ替えます。
グループを選択した状態で実行すると、そのグループが1つずつ上、または下に移動します。
・グループ階層上・下
グループの階層を入れ替えます。
グループを選択した状態で実行すると、そのグループの階層が1つずつ上または下に移動します。
・元に戻す(「編集」メニューのみ)
直前に行った操作を一つ前に戻します。複数の操作を元に戻すことはできません。
・編集前の状態に戻す(「編集」メニューのみ)
既存のファイルを編集したときに、行ったすべての編集操作を無効にして、最初にファイルを読み込んだときの状態に戻します。
[目次に戻る]

6.28 不要なキーを削除する

間違って作ってしまったキーや、現在使っているキーボードファイルで使用していないキーなどを削除します。

(1)「キーボード編集」画面で、削除したいキーを選びます。

(2) 削除するには次の3つの方法があります。

[目次に戻る]

6.29 1行、1列をまとめて削除する

行や列を、まとめて削除することもできます。

(1) 削除したい行(列)の行(列)選択ボタンを押します。

(2) 右クリック、またはメニューバーの「編集」のメニューから「行[列]削除」を選びます。

[目次に戻る]

6.30 行や列を挿入する

行や列の間に、新しく行(列)を追加することもできます。

(1) 挿入したい行(列)の行(列)選択ボタンを押します。

(2) 右クリック、またはメニューバーの「編集」のメニューから「行[列]挿入」を選びます。

メモ 一番下、または一番右に行・列を挿入する場合は、「6.3 行列数を増やす」の方法で行・列を追加することもできます。

[目次に戻る]

6.31 キーの間に隙間を入れる

オンスクリーンキーボードのキーとキーの間の隙間(区切り線)の幅を調整することができます。
グループの切れ目などに広めの隙間を設定すると、スキャンのときに分かりやすくなります。

(1) 隙間を入れたい場所の下の行の行選択ボタン、または右の列の列選択ボタンを押します。

(2) 右クリック、またはメニューバーの「編集」のメニューから「行[列]の間隔」を選びます。
「行列の間隔」画面が開きます。

(3) 何ドット隙間をあけるかを入力します。

[目次に戻る]

6.32 マウスポインタのジャンプ位置を設定する

マウスポインタを指定した位置にジャンプさせるためのジャンプ位置を登録できます。
ここでの設定は、各キーボードファイルごとに登録されます。

(1)「キーボード編集」画面のメニューバーの「ツール」→「ジャンプ位置設定」を選びます。
「ジャンプ位置一覧」画面が開きます。

(2)「座標1〜30」の中から1つを選び、「位置設定」ボタンを押します。
「ジャンプ位置設定」画面が開きます。

(3)「基準位置」の▼を押してリストを開き、基準位置を選択します。

メモ 基準位置とは?
ジャンプ位置を登録する場合、ある点から登録したいジャンプ位置までの距離を測り、その数値を登録しますが、その「ある点」が基準位置です。
また、「画面○○基準」というのはパソコンの画面全体に対しての位置、「ウィンドウ○○基準」というのは現在操作しているアプリケーションのウィンドウの中での位置になります。
特定のウィンドウの中にあるボタン等にジャンプさせたい場合はウィンドウ基準を選択しましょう。また、「右上」「右下」「左上」「左下」については、画面の解像度やウィンドウのサイズを変えたときに、ジャンプさせたい位置との距離が変わらないものを選びます。

(4)基準位置から目的の位置までの距離(単位はドット)が分かっている場合は、「横」「縦」にそれぞれ数値を入力します。分かっていない場合は「マウスで設定」ボタンを押し、画面の指示に従ってジャンプさせたい場所を直接マウスでクリックします。
画面スキャンモードやマウスキーボードを使用して、オペレートナビからマウスを操作して設定することもできます。

[目次に戻る]

6.33 キートップ、または操作列設定だけを連続して登録する

キートップや操作列の設定を、毎回「OK」ボタンを押して「キーボード編集」画面に戻らずに、連続して登録することができます。キーの配置を覚えているときや、数字を順に入れるような設定のときには便利です。

(1)「キートップ設定」、または「操作列設定」を開きます。

(2) そのキーの内容を登録します。

(3)「適用」ボタンを押します。
「適用」ボタンを押さないと、そのキーの設定が登録されません。

(4)「次のキー」または「前のキー」ボタンを押します。

(5) (2)〜(4)の操作を繰り返します。

メモ 「次のキー」ボタンで移動する順番は左から右へ、行の一番右に来たら次の行の一番左に移動します。

[目次に戻る]

6.34 既に設定されているキーをコピーする

既に作成してあるキーと同じ内容のキーを作成するときは、既にあるキーをコピーして貼り付けて使うことができます。最初からキーを作り直すより簡単にキーを作成できます。

「キーボード編集」画面を2つ開けば、片方のキーボード編集からコピーしたキーをもう片方のキーボード編集に貼り付けることができます。

(1) コピーしたいキー、またはコピーしたい行(列)の行(列)選択ボタンを押します。

(2) 右クリックまたはメニューバーの「編集」のメニューから「コピー」を選びます。

(3) 貼り付けたいキー、または貼り付けたい行(列)の行(列)選択ボタンを押します。

(4) 右クリックまたはメニューバーの「編集」のメニューから「貼り付け」を選びます。

メモ (1)でキーを選択した場合は(3)でもキーを、(1)で行(列)選択ボタンを押した場合は(3)でも行(列)選択ボタンを押して下さい。その組み合わせがあっていない場合は、(4)で「貼り付け」を選択できません。

[目次に戻る]

6.35 特定のキーボードだけ色やフォントを変更する

特定のキーボードだけ背景色やフォントの設定を変えることができます。
色やフォントの設定は、キーごとの設定(「6.14 ほかのキーと違う色やフォントのキーを作る」参照)、キーボードごとの設定、全体の設定(「3.5 配色や文字の大きさを変更する」参照)の順に優先されます。

(1)「キーボード編集」画面のメニューバーの「ツール」→「配色&フォント設定」を選択して「キーボード配色」画面を開きます。

(2)「このキーボード専用のフォントを設定する」の□にチェックを入れると、このキーボードのみフォント設定が、同様に「配色を設定する」の□にチェックを入れると、このキーボードのみの配色設定ができます。フォント、または配色のみを設定することも、両方を設定することも可能です。

(3) 色やフォントの詳細な設定については、「3.5 配色や文字の大きさを変更する」を参照してください。

[目次に戻る]

付録

標準セットファイル『1スイッチスキャン(設定付き)』には、オペレートナビ設定の操作に便利なキーボードが収録されています。

「オペレートナビ設定」プログラム操作用キーボード


▲「オペレートナビ設定」

▲「スイッチ機能設定」

▲「キーボード編集」

▲「キートップ設定」

▲「操作列設定」

▲「複合操作列編集」

▲「キー操作編集」

▲「マウス操作編集」

▲「キーボードグループ編集」

オペレートナビ設定で利用する基本的な操作(ショートカットキー)

【表】階層構造またはリスト形式の一覧で操作するショートカット
ショートカットキー 説明
[←] 項目の階層構造が[-]の場合、収束する
[→] 項目の階層行動が[+]の場合、展開する
[↑]、[↓] 項目を上下に移動する
[Shift]+[↑]
[Shift]+[↓]
連続して項目を選択する
[Ctrl]+[↑]
[Ctrl]+[↓]
飛び飛びの項目の選択
[Ctrl]を押しながら[矢印]で移動し対象の項目で[Space]を押すことで、飛び飛びの項目を選択する
[Tab] 次の設定項目に移動する
オペレートナビ設定の基本画面で左の設定欄の項目が選択されている場合は右の設定欄の先頭項目に移動する
[Shift]+[Tab] 1つ前の設定項目に移動する
オペレートナビ設定の基本画面で左の設定欄の項目が選択されている場合は右の設定欄の最後項目に移動する
[Ctrl]+[Tab] 関係付けられている設定項目に移動する
[Space] 階層構造のカーソルのある項目を選択する
【表】設定項目の並んでいる欄で操作するショートカットキー
ショートカットキー 説明
[Tab] 次の設定項目に移動する
[Shift]+[Tab] 1つ前の設定項目に移動する
[↑]、[↓] 連続したラジオボタン項目を移動する
[Ctrl]+[Tab] オペレートナビ操作の基本画面で右の設定欄から、関係付けられている左の階層構造の項目に移動する
[Alt]+[↓] リスト項目で設定内容を一覧表示する
【表】表形式の設定項目で操作するショートカットキー
ショートカットキー 説明
[←]、[→]、[↑]、[↓] セルを移動する
[Shift]+[矢印] 連続したセルを選択する
[Ctrl]+[矢印] 1行または1列を選択する
そのまま、[Ctrl]を押しながら広げる方向へ[矢印」を押すことで、複数行または複数列選択する
[目次に戻る]